Treiber für Arduino Nano Clones

469521107_1280x720Wer sich beim „Chinamann“ (z.B. Aliexpress oder Banggood) Arduino Nano Clones kauft steht recht flott vor dem Problem dass diese Clones nicht vom PC erkannt werden.
Das liegt daran dass dort statt der FTDI-Chips die deutlich preiswerteren CH340G USB 2 Serial Chips verbaut wurden.
Dies führt beim Upload von Sketches auf den Arduino zu Fehlermeldungen.
Die Clones benötigen einen eigenen Treiber. Diesen findet man kostenlos im Netz unter dem Namen CH340SER.EXE oder auch unter dem Namen CH341SER.EXE.

Ich habe für mich den Treiber hier im Blog als Backup gespeichert. Dieser funktioniert bei mir hervorragend, ich übernehme dafür allerdings weder Garantie noch Haftung. Der Download erfolgt auf eigenes Risiko.

Bevor man den Arduino mit dem PC verbindet:

  • Treiber downloaden (und ggf entzippen)
  • Setup starten
  • Die Software fragt dann nach ob sie den Treiber CH341SER.INF für den Chip CH340 (Version 11/04/2011, 3.3.2011.11) installieren darf, ‚INSTALL‘ klicken
  • Nach Installation erfolgt noch eine Windows-Meldung dass der Treiber erfolgreich installiert wurde
  • Den Arduino Nano per USB verbinden
  • Im Gerätemanager findet man dann den Eintrag „USB-SERIAL CH340 (COM XX)“ bei XX steht dann welcher COM-Port benutzt wird
  • In der Arduino Software entsprechend den COM-Port einstellen, fertig

10 Gedanken zu „Treiber für Arduino Nano Clones

  1. nachdem ein älterer Treiber nicht funktionierte war ich schon verzweifelt, aber dieser Treiber funktioniert einwandfrei. Danke Dir !

  2. SUPER!
    Das Beispiel „Blink“ blinkt :-)))
    Als Anfänger versuche ich seit 2Tagen das Teil (Nano) zur Mitarbeit zu überreden, bisher ohne Erfolg.
    Mit dem Treiber von hier alles easy.

    Danke

  3. Nun verstehe ich nichts mehr.
    Hatte den Treiber von hier wie beschrieben installiert, meinen Nano angehängt, die Beispieldatei „Blinky“ geladen und es hat geblinkt.
    Dann wollte ich einen anderen Sketch laden:
    Keine Verbindung mehr zum Nano, Port nicht vorhanden!!!

    Ich glaube, das ich den Nano in die Tonne treten werde, verstehe das hier gerade nicht mehr…

    Wer kann helfen?

    Gruß
    GeWo

  4. Hmmm… Stecker mal abziehen und neu anstecken?
    Das kann sehr viele Ursachen haben, kann das aber aus der Ferne schlecht beurteilen.

  5. bei mir funktioniert das Leider nicht, ich hab es genau so gemacht, wie beschieben
    aber en passiert einfach nichts. ) :

  6. Habe auf zwei verschiedenen PCs (WIN10 /64B) wie beschrieben installiert. Auf einem funktionierts, auf dem anderen nicht. Unterschiede:
    PC1 (i3 Prozessor Laptop) wo ess funktioniert: wird die COM3 im Gerätemanger nach der Installation angezeigt. Auf den Home PC (i7 Prozessor) wird nur die schon vorher zuvor vohanden com 1 angezeigt jedoch ohne Hinweis auf Arduino Treiber. Auf USB wird unbekanntes Gerät angezeigt. Der Versuch hier diverse Arduino Treiber zu installieren scheiterte.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.